Network configuration may cause warehouse timeout errors

Incident Report for Lightdash

Resolved

Earlier today, an additional egress IP address was unintentionally provisioned on our EU cluster. This caused some queries from Lightdash to customer warehouses to be blocked, where the new IP was not on the customer's allowlist.

We've worked directly with affected customers to apply an allowlist update, and error rates have returned to normal. We're now monitoring to confirm stability and working with our cloud provider to consolidate back to a single egress IP at the infrastructure layer.

Action required if you're still seeing warehouse connection errors: please ensure both `34.79.239.130` and `34.140.90.83` are on your warehouse IP allowlist. Our [IP allowlisting guide](https://docs.lightdash.com/get-started/setup-lightdash/connect-project#adding-lightdashs-static-ip-addresses-to-your-allow-list) has been updated to reflect the current EU egress IP set and includes step-by-step instructions.

We apologise for the disruption.
Posted Apr 21, 2026 - 14:48 UTC

Identified

We unintentionally added a new external IP address for customers in the EU. Customers using firewalls for their warehouse may see unexpected requests from: 34.140.90.83 - we are fixing this now.
Posted Apr 21, 2026 - 11:37 UTC
This incident affected: Lightdash Cloud (Lightdash Cloud (EU)).