Degraded database performance (US)

Incident Report for Lightdash

Resolved

Services stable, incident has been resolved.
Posted May 06, 2026 - 16:55 UTC

Monitoring

Systems are stable, fix has been applied successfully. Monitoring system vitals.
Posted May 06, 2026 - 15:42 UTC

Identified

A fix has been applied to the database and is rolling out.
Posted May 06, 2026 - 15:32 UTC

Investigating

We're investigating elevated database latency on Lightdash Cloud (US). Queries may be slower than usual. EU is unaffected.
Posted May 06, 2026 - 15:14 UTC
This incident affected: Lightdash Cloud (Lightdash Cloud (US)).