Intermittent API errors across US

Incident Report for Lightdash

Postmortem

Root cause
Our cloud networking layer had insufficient capacity to handle the volume of outbound connections from our services. As traffic grew, we periodically exceeded the available connection limits, causing some requests to be dropped.

What we fixed
We restructured our internal network architecture, significantly reducing the load on our outbound connection layer. This freed up capacity.

Ensuring it won’t happen again

We’ve permanently re-architected to prevent this specific issue. We’ve added monitoring + alerts to catch similar network errors.

Posted Mar 24, 2026 - 12:23 UTC

Resolved

We've seen no errors related to network configuration.
Posted Mar 24, 2026 - 12:19 UTC

Monitoring

We have deployed a fix to our network configuration and all services are healthy. We will continue monitoring.
Posted Mar 24, 2026 - 11:34 UTC

Update

We are continuing to work on a fix for this issue.
Posted Mar 24, 2026 - 10:36 UTC

Update

We are continuing to work on a fix for this issue.
Posted Mar 24, 2026 - 10:35 UTC

Identified

We have identified an issue in our network configuration that is leading to some requests failing. We've identified fix and are deploying to production.
Posted Mar 24, 2026 - 10:35 UTC
This incident affected: Lightdash Cloud (Lightdash Cloud (US)).