Degraded performance

Incident Report for Lightdash

Resolved

This incident has been resolved.
Posted Apr 14, 2025 - 11:35 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 14, 2025 - 10:33 UTC

Update

We are continuing to investigate this issue.
Posted Apr 14, 2025 - 09:11 UTC

Investigating

Users reporting degraded performance and timeout errors. We are investigating the issue.
Posted Apr 14, 2025 - 09:11 UTC
This incident affected: Lightdash Cloud (Lightdash Cloud (US), Lightdash Cloud (EU)).